Concierge failing to auto-sync

Options
pezza
pezza Expensify Customer Posts: 15 Expensify Newcomer

Hi, I have recently started to get notifications from Concierge about an error while auto-syncing.

The error that I get is:

"We were unable to set [xx] as the exporter of your policy connection because they are not currently set as an admin.

Once you manually resolve these errors, auto-sync should resume"

Where xx is my admin email account used.

What I don't understand is where is this setting? Is it in QuickBooks or is it in Expensify?

I have looked in Expensify in my policy and this account is set up as Policy admin and it is the account that is used to login to my QuickBooks. I can't see where else I have something not set up as admin.

So I am a bit baffled as to how and where I am supposed to set this manually.

Thanks

Andrew

Answers

  • Isabela Stisser
    Isabela Stisser Expensify Team, Expensify Student Ambassador Posts: 200 Expensify Team
    Options

    Hi @pezza, thanks for reaching out!

    I checked your account and see that you have Submit and Close selected as the approval mode for your policy, and there are two emails listed there but none of them are set as a Policy Admin. You will need to first set one of those emails as a policy admin and then head to your QuickBooks configuration in Expensify and select a preferred exporter for your policy.

    First, to change an employee role to Admin please head to Settings > Policy > Policy Name > People and click on the blue clog settings:

    Then head to Settings > Policy > Policy Name > Connections > Configure and select a preferred exporter for your policy:

    Once that's done, you should stop getting this auto-sync error message from Concierge.

    Let me know if you have questions and I will be happy to help!

  • pezza
    pezza Expensify Customer Posts: 15 Expensify Newcomer
    edited November 2018
    Options

    Thanks @IsabelaStisser

    This is weird, as when I look at this, I see that it IS set as Policy Admin :-(

    I might try to change it to None, and then re apply to admin to see if that helps, but other than that, I am not sure why I am seeing a difference to what the system (and yourself) is seeing.

    Thanks

    Andrew

    Edit: Actually I wonder if I need to apply any updates? Has there been an update to Expensify that I will need to manually apply?

    Edit2: It won't let me change this as it tells me that I cannot edit my own. Also I am noticing that everytime I run a sync, or try to re-apply/configure the connections, it signs me out to the login page

  • Isabela Stisser
    Isabela Stisser Expensify Team, Expensify Student Ambassador Posts: 200 Expensify Team
    Options

    Hey @pezza! I just checked your account again and see that your email is listed as the Policy Admin now. I also checked your Configuration settings in QuickBooks and see your email listed as the preferred exported as well!

    You should be good to go! ;)

  • pezza
    pezza Expensify Customer Posts: 15 Expensify Newcomer
    Options

    Thanks @IsabelaStisser

    For some reason it is still kicking me out whenever I do a synch.

    I have never noticed this before, but i'm pretty sure that it didn't used to do this.

    Is this a problem?

    Wondering when that admin was updated, as I got an email this afternoon to say that it failed again, so I guess if it was re-set after then, then hopefully future ones will work, but I still don't get why it is logging me out at the end of a synch or when I save the connection settings

    Thanks

    Andrew

  • pezza
    pezza Expensify Customer Posts: 15 Expensify Newcomer
    Options

    Hi,

    So this weekend, I have had more emails about the same failure and it was still kicking me out each time I did a synch.

    So today, I decided to bite the bullet and I disconnected Quickbooks from my policy. I wanted to avoid doing this as I wasn't sure what I would lose, or if I might not get it back, but decided to risk it.

    So far (and I am hoping that I have set all the options up correctly :-) ) it seems to have established the new connection OK without any errors, and I haven't been kicked out of Expensify when I have just done a manual synch, so hopefully all is now OK. I guess I will know in the next few days if I have stopped receiving the email about the failures/

    Still no idea what the issue was, but when all else fails, give it a reboot!

    Thanks

    Andrew