We are currently experiencing higher than normal support inquiries and response times. The Community is here to support you as well so please help each other out when you can. Please visit our status page to subscribe to updates.

NetSuite: Coding Configurations - Department "Tags" - Populate Default DepartmentValue from NetSuite

BinduBindu Expensify NewcomerPosts: 9Expensify Customer Expensify Newcomer
  • The above link says - Defaults on employee record in NetSuite will be applied to all the expenses created for that employee - is that within Expensify? Since we have default Department for employees within Netsuite and have selected "Tag(line-item Level) for Departments in the Coding section"
  • Can you please let us know if its possible to populate the Departments in Expensify from Netsuite's Employee configuration.
Tagged:

Answers

  • Sheena TrepanierSheena Trepanier Expensify Success Coach Posts: 1,992Expensify Success Coach - Admin Expensify Success Coach

    Hi @Bindu, thanks for posting!

    If you have default departments on the employee record in NetSuite, those defaults should be applied to expenses created by that employee in Expensify.

    If you also enable Departments as tags in Expensify, then you'd see the default from NetSuite applied but each employee would then be able to change the default department by changing the tag on the expense.

    Does that make sense?

    Do you have employees with defaults in NetSuite that aren't being applied in Expensify since switching to tags?

  • BinduBindu Expensify Newcomer Posts: 9Expensify Customer Expensify Newcomer

    Hi @Sheena Trepanier - Thanks for the response , thats what we were expecting to happen as well , but we have Employees defaulted with Departments in NetSuite and also enabled Departments as tags in Expensify , but still do not see the Default Department populated for Employees on the expenses.

    Is this something you can help with.

    Attaching screen shots as reference.


  • Sheena TrepanierSheena Trepanier Expensify Success Coach Posts: 1,992Expensify Success Coach - Admin Expensify Success Coach

    @Bindu, I did some digging and checking of things on the backend and can see that the proper department is being applied to your account in Expensify, so the connection there is working well.

    Have you by any chance exported a report in Expensify that included an expense without the department tagged?

    If so, did the department get applied during the export process? If not, would you be able to test a single expense report, without a department applied, and let me know if the department is applied during the export process?

    I'm going to do some testing with our instance of NetSuite and confirm the behavior we're seeing as well. I can't find a record of this behavior changing but it's also something I don't have to look at very often and hey, we're all humans who can miss an email.

  • BinduBindu Expensify Newcomer Posts: 9Expensify Customer Expensify Newcomer
    edited October 4

    Thanks @Sheena Trepanier for the response.

    So will the Employee's 'Department' get populated only on the Export of the Expense Report from Expensify and will it not show up (populated by default) on the 'New Expense' for an employee when an Employee creates a New Expense.

    Please refer the screenshot shared on Oct 3, we are expecting the 'New Expense' screen's 'Department' to be auto-populated with NetSuite's Employee's Department.

    Is that possible ?

  • Sheena TrepanierSheena Trepanier Expensify Success Coach Posts: 1,992Expensify Success Coach - Admin Expensify Success Coach

    Hi @Bindu, thanks for circling back. I'm still in the testing process for this and will follow up as soon as I've confirmed it.

    If the integration only applies the department at the export, the ideal solution can still be achieved with a few minutes of manual work for the employee. The solution would be for employees to create a universal Expense Rule that applies a specific department tag to each expense. If the employee needed to change the department on a specific expense they would be able to do so.

    If we need to go down that route, I'll prepare some instructions and screenshots you can share with employees. Talk to you soon!

  • Sheena TrepanierSheena Trepanier Expensify Success Coach Posts: 1,992Expensify Success Coach - Admin Expensify Success Coach

    Hi @Bindu, thanks for the patience! I've confirmed that the tag should be applied automatically to each new expense, as long as expense rules aren't already in place and changing the tagging.

    Can you create one new test expense, name it test please, and then don't add any coding at all. Simply add the merchant, date and amount to the expense then save it and let me know here. I'll take a closer look at the expense, the behind the scenes tagging information, and escalate appropriately.

    Thanks!

  • BinduBindu Expensify Newcomer Posts: 9Expensify Customer Expensify Newcomer

    Hi @Sheena Trepanier - Created the Expense 'Test' and saved it.Also attaching a screen shot - Can you please check and let us know the updates/feedback.


  • Nicole TrepanierNicole Trepanier Expensify Success Coach Posts: 699Expensify Success Coach - Admin Expensify Success Coach

    Hi @Bindu While looking at your account, I did notice that Customers is the first tag and Departments is the second tag. This places a : in the rule that I think may be causing it to not work. Can you try disabling Customers, sync your policy, then enable customers to see if it moves the department tag to being first. I can check the backend to see if the rule is corrected.

  • BinduBindu Expensify Newcomer Posts: 9Expensify Customer Expensify Newcomer

    Hi @Nicole Trepanier - This seems to be taking long and it will be good if you can confirm what the exact root cause is and the resolution for the same, instead of trying options , (we shall still try the option that you have mentioned) as this is causing a lot of issues on our end and we might have to reconsider continuing with Expensify in case we are not able to get this issue resolved.Kindly request you to share the root cause / fix for the same.

  • Nicole TrepanierNicole Trepanier Expensify Success Coach Posts: 699Expensify Success Coach - Admin Expensify Success Coach

    @Bindu Because there are account actions I can't take on your account, we need to try these steps in order to identify the rood cause and fix. It is my belief that there is a colon stuck at the beginning of your tag that's causing the issue and if I'm right this should resolve it. If I'm wrong, then I'm going to reach out to you directly for further troubleshooting.

  • BinduBindu Expensify Newcomer Posts: 9Expensify Customer Expensify Newcomer

    Thanks @Nicole Trepanier , we have disabled the customers , synced and then re-enabled , but still not getting the 'Department' auto populated.

  • Nicole TrepanierNicole Trepanier Expensify Success Coach Posts: 699Expensify Success Coach - Admin Expensify Success Coach

    @Bindu I've reached out to you directly and will update this thread once we've found a resolution.

Sign In or Register to comment.