Are you receiving SNAP/EBT benefits? The Expensify.org/SNAP-VAX campaign is live and accepting new members. Learn more about receiving $50 for submitting a SNAP receipt and $50 for getting your COVID-19 vaccine here and join today!

FAQ: NetSuite: You Do Not Have Permissions to Set a Value for Element...

Christina Dobryzynski
Christina Dobryzynski Expensify Success Coach - Admin, Expensify Team, Expensify Student Ambassador Posts: 257 Expensify Team
edited March 18 in Integrations and API

ExpensiError NS0056: You do not have permissions to set a value for element...

Common Element Errors

Error message: "You do not have permissions to set a value for element ..."

  • class
  • location
  • memo
  • amount
  • isnonreimbursable
  • department
  • exchangerate

In NetSuite, go to Customization > Forms > Transaction Forms then search for the form type that the report is being exported as in NetSuite (Expense Report, Journal Entry, or Vendor Bill) and click Edit next to the form that has the Preferred checkbox checked.

If the report is being exported as a Journal Entry:

  • Go to Screen Fields > Lines > make sure the field listed in the error has the Show checkbox checked.

If the report is being exported as a Vendor Bill:

  • Go to Screen Fields > Main > make sure the field listed in the error has the Show checkbox checked.

Other Element Permissions Errors

Error Message"NetSuite Error: You do not have permissions to set a value for element line.entity"

  1. Customization > Forms > Transaction Forms > search for Journal Entry and Edit the form that has the Preferred Checkbox checked.
  2. Screen Fields > Main > make sure that the Name field has the Show checkbox checked.

-----------------------------------------------------------------------

Error Message"Error creating Vendor: You do not have permissions to set a value for element entityid"

This error can occur in a couple contexts. In many cases, the solution will likely be to access the Vendor Entry form via Customization > Forms > Entry Forms > search for Vendor and choose to Edit the form that has the Preferred Checkbox checked, ensuring that the Vendor ID field is set to Show, Quick Add, and Mandatory.

If this does not solve the issue, search for Auto-Generated Numbers in the NetSuite search bar:


Note: Make sure to include the hyphen when searching!

Then, either disable Auto-Generated Numbers for Vendor, or check Allow Override.

-----------------------------------------------------------------------

Error Message"NetSuite Error: You do not have permissions to set a value for element entityID"

We'd recommend first making sure that you have the most recent version of the Expensify bundle installed in NetSuite. If you do, then follow these steps:

  1. Customization > Forms > Transaction Forms > search for Vendor Bills and Edit the form has the Preferred Checkbox checked.
  2. Screen Fields > Main > make sure that the entityID field has the Show and Mandatory checkboxes checked.

-----------------------------------------------------------------------

Error Message: "You do not have permissions to set a value for element supervisor approval due to one of the following reasons"

  1. Customization > Forms > Transaction Forms > search for Expense Report and Edit the form has the Preferred Checkbox checked.
  2. Screen Fields > Main > make sure that the Supervisor Approval field has the Show checkbox checked.


-----------------------------------------------------------------------

Error Message"You do not have permissions to set a value for element approvalstatus due to one of the following reasons"

  1. Customization > Forms > Transaction Forms > then search for the form type that the report is being exported as in NetSuite (Expense Report, Journal Entry, or Vendor Bill) and click Edit next to the form that has the Preferred Checkbox checked.
  2. Screen Fields > Main > make sure that the Approval Status field has the Show checkbox checked.
  3. If this does not resolve the error, you also have the option to disable approval routing in your NetSuite settings. To do this, go to Setup > Accounting > Accounting Preferences > Approval Routing and make sure Vendor Bills and Journal Entries are not selected.

If you're seeing the "You do not have permissions to set a value for element approvalstatus" and you're exporting as Vendor Bills, you can check a few more permissions items:

  • Go to Manage Roles > Expensify Integrations > Edit > Permissions > Transactions > add "Approve Vendor Payments" > apply Full as the access level.
  • Whilst there choose Forms and make sure the Vendor Bill Transaction Form you're exporting to (your preferred one) is Enabled there.

Those are the only restrictions from our export permissions that could prevent us from setting them as Approved. If these are all set up, you'll need to refer you to whatever you have set up in "Customization > Workflows" or any specific approval you have enabled for the expense categories used on this report.

The only other way around this is to simply set the Default approval workflows up when exporting from Expensify, which is done from Settings > Policies > Group [Policy Name] > Connections > Accounting Integrations under the Advanced tab in the NetSuite configuration window:

-----------------------------------------------------------------------

Error Message"You do not have permissions to set a value for element usemulticurrency"

Check out this section of the NetSuite FAQ guide to make sure you have Multi-Currency setup correctly in NetSuite. 

-----------------------------------------------------------------------

Error Message"You do not have permissions to set a value for element expense.foreignamount"

Check all of your NetSuite Expense Categories for a setting called Rate is Required. Disable that setting for all Expense Categories, and sync your NetSuite connection in Expensify. Then, try to sync a report to NetSuite again to confirm this works for you!

------------------------------------------------------------------------

Error Message"You do not have permissions to set a value for element tranid"

Check your NetSuite setup to "Allow Override" for Invoices from "Set Up Auto-Generated Numbers":

-----------------------------------------------------------------------

Error Message"You do not have permissions to set a value for element memo"

Confirm the report you are trying to export does not have a negative reimbursable total amount. Only reports with a positive reimbursable total amount can export to NetSuite.

Related articles:


Tagged:

Comments