FAQ: NetSuite: Expense Does Not Have Appropriate Permissions for Setting an Exchange Rate

Christina Dobryzynski
Christina Dobryzynski Expensify Success Coach - Admin, Expensify Team, Expensify Student Ambassador Posts: 268 Expensify Team
edited December 2019 in Integrations and API

Should you run into the ExpensiError NS0085 - Expense Does not Have Appropriate Permissions for Settings an Exchange Rate in NetSuite error, you will find instructions below to resolve it.

Step 1

In NetSuite, go to Customization > Forms > Transaction Forms then search for the form type that the report is being exported as in NetSuite (Expense Report, Journal Entry, or Vendor Bill,) and click Edit next to the form that has the Preferred checkbox checked.

Step 2

If the report is being exported as an Expense Report:

  • Go to Screen Fields > Expenses (the Expenses tab farthest to the right) >  make sure the field Exchange Rate under the Description column has the Show checkbox checked.

If the report is being exported as a Vendor Bill:

  • Go to Screen Fields > Main > make sure the field Exchange Rate under the Description column has the Show checkbox checked.

If the report is being exported as a Journal Entry:

  • Go to Screen Fields > Lines > make sure the field Exchange Rate under the Description column has the Show checkbox checked.
  • Go to Screen Fields > Main > make sure the field Exchange Rate under the Description column has the Show checkbox checked.

Step 3

Click Sync Now to the NetSuite connection at Settings > Policies > Group > [Policy Name] > Connections and export the Report(s) again.

If this doesn't resolve the error, reach out to use via Concierge.

Tagged: