How do I stop auto report assignment.

I cannot figure out how to stop expensify/concierge from automatically assigning a reciept that I scan into a particular report. The auto report choice is never and I mean never correct, and I have to go back in one by one and correct the reports they get grouped in. Sometimes they get lost in reports from a year ago that are not remotely relevant. The absolute worst was when somehow concierge auto submission got turned on, and reports that were not done one day just were submitted randomly. Quite the ghost in the machine. Otherwise I do love expensify.

Thanks in advance!

Best Answers

Answers

  • PDepuhlPDepuhl Posts: 4

    Buried treasure. Thanks for pointing this out. I had the same issue, where Concierge would randomly pick incorrect reports (sometimes closed ones from last year) and burry expenses in them for me to go hunt for. No fun.

    I just turned them off and am hoping this works from here on out…

  • PDepuhlPDepuhl Posts: 4

    I have BOTH of these turned off, nevertheless Expensify still randomly assigns expenses to expense reports. Sometimes. Not always, and never to the last report I've opened.

  • Conor PendergrastConor Pendergrast Posts: 85 admin

    Hey @PDepuhl Concierge will only add receipts to Open reports. Do you submit or close your reports once you're finished with them? That's the expected behaviour here.

    Thanks!

  • gregkeenegregkeene Posts: 1

    I have the same problem. I do not have schedule submit turned on and it assigns them to a report. But what's worse is that with your 2018 update now I can't move (or can't figure out how) an expense from one report to another (at least not consistently). This is a huge issue because the exporting of a report is what defines which chart of account it's assigned to. So managed card expenses can't be with cash, etc. Please help.

  • XofXof Posts: 1
    edited February 12

    This is now happening to me, and it is pretty much breaking Expensify for me. When I drag a new receipt to the Expensify window, it either creates a new report and assigns the expense to it, or assigns it (at random, as far as I can tell) to an open report if there are any.

    Neither of these is what I want. What I want is for it to be left unassigned so I can assign it later to a report of my choosing.

    "Scheduled Submit" is turned off in both places.

    This is new behavior; it was working properly as recently as two weeks ago.

  • drhaazdrhaaz Posts: 13

    Same thing happened here. It's enough of a nuisance I have to make sure our staff doesn't accidentally sign up for auto submit on their accounts. Now it's doing it on everyone's accounts regardless

  • n8barbern8barber Posts: 2

    I'm having this same issue. Scheduled submit is turned off EVERYWHERE. Still, new expenses are added to open expense reports. I have several open at a time, by necessity. I just want unassigned, new expenses to REMAIN UNASSIGNED and UNREPORTED so I can add them to the correct reports. Why is this so hard?

  • MwalMwal Posts: 3

    I've just come across this exact same problem and I also do not have auto-scheduler on. Sure, perhaps it only put's them in open reports, however, it is virtually never the correct report, almost as though it's choosing the report at random.

    I agree with another comment here that this renders Expensify useless. I have to search for everything that I either photograph, scan, or forward, which alone takes hours. I'm also relying on Smart Scan to get everything completely accurate to find it with this search, so any minor error means that I'll never find it and it's stuck in an incorrect report which will be filed with errors down the road.

    I hope this is just a glitch with a new update and will be fixed ASAP as I've advised everyone to stop adding new expenses effective immediately.

  • DannyDDannyD Posts: 3
    edited February 26

    Same: Scheduled submit is off but expenses still being auto-added to new reports. Please fix!

  • KevinLKevinL Posts: 10

    Hi Conor. When you mention expected behavior is to submit reports when an expense is added, it doesn’t match our company’s behavior. Our employees have several reports open during the month and submit them all at the beginning of the next month. My question is why do employees get the auto submit preference turned on even if I’ve turned it off for the entire domain? Do I have to tell each new user to go into preferences to turn it off when they open an Expensify account?

  • mmain19mmain19 Posts: 1

    Same issue here. I have Scheduled Submit turned off (I mean, who doesn't want to review their report before it gets blindly sent in??) and when I upload a receipt it is auto assigned to the worst possible report. I have to Private Eye it and figured out which receipts are now in the wrong report and move them. It makes so much more sense for it to not be assigned to any report. Then I filter by "unreported", check all that apply and move them to the correct report.

  • RachCHopkinsRachCHopkins Posts: 717 admin

    Hi @mmain19 Welcome to the Expensify Community! This is because Scheduled Submit is turned on on your default Policy.

    You can either change your Default Policy to be '(none)' or you can speak to your Policy Admin about this setting. :)

  • L_ZL_Z Posts: 3

    This is by far the most infuriating part of Expensify.
    1. It was turned on without warning and finding what was happening was difficult
    2. The solution is buried with menus and sub-menus
    3. I turned off as instructed and it is still happening
    4. I lose a ridiculous amount of time manually finding where the "auto-classified" receipts are

    Maybe this is useful to someone but PLEASE add a button to turn this off!!!!

  • Onthefly71Onthefly71 Posts: 3

    Yes please add a quick remove button for that feature it’s awful!

  • RachCHopkinsRachCHopkins Posts: 717 admin

    Hi @Onthefly71 and @L_Z , if you don't have Scheduled Submit turned on in your Personal settings, this means it's controlled by your Policy Admin and you will need to discuss this with them as Scheduled Submit is generally in place for a reason.

    But if you are the Policy Admin, it's just an on/off toggle found in Admin > [Policy Name] > Reports. Can't get much quicker than that!

    The fastest way for a user to see what reports their expenses are on is simply by going to the Expenses page. If an extra report was created by Scheduled Submit, you can simply delete it to return the expenses to Unreported and pop them on a different report.

    @L_Z can you give an example of a couple of expenses which have been added to a report automatically since you disabled Scheduled Submit? I'd like to take a closer look.

  • L_ZL_Z Posts: 3

    I am the admin
    The admin -> Policy -> Report -> Scheduled Submit is toggled OFF
    I scanned a couple of receipts today (Jun 4, 2018). Right now, they are being smart-scanned but I can see that they have already been auto-submitted to my report AMQ018-05 (the wrong report)
    (If you need a link, an url or some identifier, just let me know how to produce it)

    BTW, if expenses were filed exclusively under "new reports", I suppose I could just go to any "new report" and re-classify them. The problem is that they are usually filed under an existing report. SO I need to open EVERY SINGLE report and check EACH and EVERY expense if they were auto-classified expenses.
    1 - That takes a LOT of time
    2 - If I miss even 1 receipt, I can either not get reimbursed for an expense (OR invoice the wrong client)

  • RachCHopkinsRachCHopkins Posts: 717 admin
    edited June 5

    Thanks @L_Z, I have checked the report and it's definitely not doing any automated reporting.

    However, I suspect what might be happening is a sticky report name field - did you use the mobile app? The Report name field is 'sticky' on the app, meaning that it remembers the last report you added an expense to via the app (in order to save time).

    My guess is some time in past you selected the report while smartscanning, and that report still exists and so it's still using that setting.

    Next time you add an expense tap 'Add Details/More' and set it to 'None'. This should break the cycle.

    It seems that your entire headache here is being caused by this auto-adding, so we need to track it down and nip it in the bud asap. Please let me know if this solution helps!

  • L_ZL_Z Posts: 3

    How do I do that? When I take a picture on the app and it starts scanning, the report is already there. If I press it down, the only option is to delete. If I click, it takes me to the expense. I can change the report (it stops the scan) but the next time I take a picture, it is still automatically putting it on a report.

  • Sheena TrepanierSheena Trepanier Posts: 1,513 admin

    Hi @l_z thanks for that information. Can you please log out and in on the mobile app before you take a photo of your next receipt?

    If this doesn't clear the report applied when a photo is taken, please let me know!

Sign In or Register to comment.