Cannot Sync on Windows 10

Got a new laptop with windows 10, got the synchronizer re-installed, and I cannot get Expensify to sync with QB Desktop Pro 2017. I've tried everything the help page says and I still get "Please make sure you are logged in as administrator in QuickBooks and try again."

I need some help!

Answers

  • Ted PeetersTed Peeters Posts: 261 Expensify Success Coach

    Hi @centrie07, thanks so much for posting here on the Expensify Community! Most often, the root causes of these QuickBooks Desktop issues can be diagnosed by our support team who can dig into your log-files and look at your policy setup, so I'd advise reaching out there if my initial advice here doesn't do the job!

    What you're explaining sounds most like your permissions might not be set-up correctly in QuickBooks Desktop. To reset the permissions for your QuickBooks Desktop connection, first, sign into QuickBooks as an Admin in single-user mode and go to Edit > Preferences > Integrated Applications > Company Preferences. From there, remove any instance of "Expensify Sync Manager" that you see listed. Save this change and click "Ok" to close the dialog box.

    Next, try to sync your policy again in Expensify. You'll be prompted to re-authorize the connection in QuickBooks.

    • Click "Yes, always; allow access even if QuickBooks is not running."
    • Select the Admin user from the dropdown then click "Continue." Selecting "Admin" does not mean you will always need to be logged in as an admin to use the connection. This is just required to create the connection.
    • Click "Done" on the pop-up and navigate back to Expensify where your policy should finish syncing.

    If this doesn't do the trick, reach out to [email protected] and reference this thread so we can dig into this a bit more for you!

Sign In or Register to comment.